Back to overview
Resolved
Percentage demographic data variables may be incorrect
Aug 10, 2026 at 5:07pm UTC
Affected services
app.growthfactor.ai
data-app.growthfactor.ai/healthz
Resolved
Aug 10, 2026 at 6:30pm UTC
This issue is now resolved
Affected services
Created
Aug 10, 2026 at 5:07pm UTC
We are seeing issues with the correctness of our % demographic data. We are investigating this issue actively.
Affected services