Back to overview
Resolved

We are upgrading our infrastructure. Deals may be unavailable at this time.

Sep 1, 2026 at 1:01am UTC  –  Sep 1, 2026 at 1:11am UTC
Affected services
app.growthfactor.ai
data-app.growthfactor.ai/healthz

Resolved
Sep 1, 2026 at 1:11am UTC

Maintenance ended

Updated
Sep 1, 2026 at 1:11am UTC

Deals maintenance has been completed.

Created
Sep 1, 2026 at 1:01am UTC

We are upgrading our infrastructure. Deals may be unavailable at this time.