Back to overview
Degraded

We're experiencing elevated latency affecting our service, and revenue forecasting may be delayed or temporarily unavailable. We've identified the issue and our team is working on a fix.

Jun 4, 2026 at 2:20pm UTC
Affected services
app.growthfactor.ai

Resolved
Jun 4, 2026 at 2:30pm UTC

The latency issue is resolved.

Created
Jun 4, 2026 at 2:20pm UTC

We're experiencing elevated latency affecting our service, and revenue forecasting may be delayed or temporarily unavailable. We've identified the issue and our team is working on a fix.