Back to overview
Resolved
PDF Exports causing Page Unresponsive for some users
Jul 9, 2026 at 10:10pm UTC
Affected services
app.growthfactor.ai
Resolved
Jul 10, 2026 at 3:05pm UTC
This issue is resolved.
Affected services
Created
Jul 9, 2026 at 10:10pm UTC
There was an issue where certain long addresses were causing PDF export issues. The fix has been identified and is on the way
Affected services