Back to overview
Resolved
Degraded agent performance due to Gemini outage
Jul 28, 2026 at 7:13pm UTC
Affected services
app.growthfactor.ai
Resolved
Jul 28, 2026 at 8:37pm UTC
We have switched providers and resolved the issue.
Affected services
Created
Jul 28, 2026 at 7:13pm UTC
Some users are currently experiencing issues with our agent. Our team is actively working with Google to resolve.
Affected services